<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://lasvegas.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="ntare guma mbaho mwine, ntare guma mbaho mwine the chi, chi showtime, lena waithe, common" />
<meta name="keywords" content="ntare guma mbaho mwine, ntare guma mbaho mwine the chi, chi showtime, lena waithe, common" />
<meta property="fb:pages" content="189162501094872" />
<title>&#8216;We Need To Have Diverse Stories&#8217;: Ntare Guma Mbaho Mwine On Showtime&#8217;s &#8216;The Chi&#8217; &#8211; CBS Las Vegas</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS Las Vegas &raquo; Feed" href="https://lasvegas.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Las Vegas &raquo; Comments Feed" href="https://lasvegas.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Las Vegas &raquo; &#8216;We Need To Have Diverse Stories&#8217;: Ntare Guma Mbaho Mwine On Showtime&#8217;s &#8216;The Chi&#8217; Comments Feed" href="https://lasvegas.cbslocal.com/2020/07/09/ntare-guma-mbaho-mwine-the-chi/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://lasvegas.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsJCICgvEWfIxJapjR/mI6xNSNqygEivbY7/RGB5JOeGKXKHeMWIBZ4sicYYgsKPmX1IpcBOpmPe93cFPEEaLfmVTRhLjv8OJ2hy4QBTfqG/M26DX7fA4UNGwmTEPmw9F9ZBLlbThpdWjRcsmkKLAy/9TIfWJ6/j3Gi8HfdLTdNZH/QR14J9p' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://lasvegas.cbslocal.com/_static/??-eJyNy8EJgDAMQNGFrEGwVA/iLDUGFdK0kIi4vXYB8fp5H67iMIuRGNhOiRRwUccZI4PazdSiagNf7BDkc61JFUrcyBmlwtF+vHUhfqOYVj2nqfODD2H0vX8AIh45LA==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://lasvegas.cbslocal.com/_static/??-eJy1kdtOwzAMhl+IzKCNiV0gnsV1rC7UOShxV/Xtl3ZsE0xC5IK7P7b/z4fAlAzFoBwU9MieC1BXjERCgSRj70IBH+0oNbMWGI8Be85ApUbmxLtNVU/wG8gFktEuoeqZnGWj7JOgcmk0J8z6B8/PycsxZqV4pdyfDe3Zd2wv/lUacUUNoaLEvnGNuoUjYXO6H+9b3lY0dNU41C5dxjxD0Vl4411o375evGe9XX/R7ZDHz/eYhwV7qacoMf8DN544T9kpP6D9aK6wT9aENKz2L72Uf/j3l9fDbvt82L9tzzcCGNs=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://lasvegas.cbslocal.com/_static/??-eJy1UNEOwiAM/CGRTGPUB+O3MKjYWcocZcv+Xlx80Cc3E18obe+u1+qhVTayAIuWKwRI2tZJUbSGNLKl7EqpSbqNNF6QaB2Q101a6bnEZhajpeyRkw7RZSod4yZyCarfvCt8SN8zdOMrfAWogL4zAj/5mQAqGDYeuqf0R0GVeTeJ7aLDXDJbwcjpH4aASsaSFjky7goJ+3kXKnhPsTa0bEQnaAkWrzug8yCTxOtbJM7hVO2O1WFb3n3zAHYdCoI='></script>
<link rel='https://api.w.org/' href='https://lasvegas.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://lasvegas.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://lasvegas.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://cbsloc.al/3iIsZpP' />
<link rel="alternate" type="application/json+oembed" href="https://lasvegas.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flasvegas.cbslocal.com%2F2020%2F07%2F09%2Fntare-guma-mbaho-mwine-the-chi%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://lasvegas.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flasvegas.cbslocal.com%2F2020%2F07%2F09%2Fntare-guma-mbaho-mwine-the-chi%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="&#039;We Need To Have Diverse Stories&#039;: Ntare Guma Mbaho Mwine On Showtime&#039;s &#039;The Chi&#039;" /><meta property="og:image" content="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/TheChi_303_0339_R-e1594320812153-11.jpg?w=1023" /><meta property="og:image:secure_url" content="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/TheChi_303_0339_R-e1594320812153-11.jpg?w=1023" /><meta property="og:image:width" content="1023" /><meta property="og:image:height" content="684" /><meta property="og:description" content="The star of &quot;The Chi&quot; on Showtime discusses the many layers of his character Ronnie Davis and why this show is so important today with the conversations happening nationally about racial injustice." /><meta property="og:type" content="article" /><meta property="og:url" content="https://lasvegas.cbslocal.com/2020/07/09/ntare-guma-mbaho-mwine-the-chi/" /><meta property="article:published_time" content="2020-07-09T13:22:44+00:00" /><meta property="article:suggested-social-copy" content="The star of &quot;The Chi&quot; on Showtime discusses the many layers of his character Ronnie Davis and why this show is so important today with the conversations happening nationally about racial injustice." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Entertainment,Only CBS" /><meta property="article:publisher" content="https://www.facebook.com/CBSLocal/" /><meta property="article:author" content="https://www.facebook.com/CBSLocal/" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/TheChi_303_0339_R-e1594320812153-11.jpg?w=1023"><meta name="twitter:title" content="&#039;We Need To Have Diverse Stories&#039;: Ntare Guma Mbaho Mwine On Showtime&#039;s &#039;The Chi&#039;"/><meta name="twitter:description" content="The star of &quot;The Chi&quot; on Showtime discusses the many layers of his character Ronnie Davis and why this show is so important today with the conversations happening nationally about racial injustice."/><meta name="twitter:site" content="/CBSLocal"/>
<link rel="canonical" href="https://lasvegas.cbslocal.com/2020/07/09/ntare-guma-mbaho-mwine-the-chi/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://lasvegas.cbslocal.com/2020/07/09/ntare-guma-mbaho-mwine-the-chi/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/lasvegas.cbslocal.com","url":"https:\/\/lasvegas.cbslocal.com","name":"CBS Las Vegas","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/lasvegas.cbslocal.com\/wp-content\/uploads\/sites\/15909905\/2018\/07\/2_cbs_lasvegas.png?w=244"}},"url":"https:\/\/lasvegas.cbslocal.com\/2020\/07\/09\/ntare-guma-mbaho-mwine-the-chi\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/lasvegas.cbslocal.com\/2020\/07\/09\/ntare-guma-mbaho-mwine-the-chi\/"},"headline":"&#8216;We Need To Have Diverse Stories&#8217;: Ntare Guma Mbaho Mwine On Showtime&#8217;s &#8216;The Chi&#8217;","description":"The star of \"The Chi\" on Showtime discusses the many layers of his character Ronnie Davis and why this show is so important today with the conversations happening nationally about racial injustice.","image":"https:\/\/lasvegas.cbslocal.com\/wp-content\/uploads\/sites\/15909905\/2020\/07\/TheChi_303_0339_R-e1594320812153-11.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Entertainment","Only CBS","Common","DJ Sixsmith","Lena Waithe","Ntare Guma Mbaho Mwine","The Chi","'We Need To Have Diverse Stories': Ntare Guma Mbaho Mwine On Showtime's 'The Chi'"],"datePublished":"2020-07-09T13:22:44+00:00","dateModified":"2020-07-09T13:22:44+00:00","video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"Ntare Guma Mbaho Mwine On Showtime's \"The Chi\"","description":"Season 3 of \"The Chi\" is on Showtime now and the show's lead actor talks with CBS Local's DJ Sixsmith about the evolution of the series, playing Ronnie Davis and working with Leonardo DiCaprio in \"Blood Diamond.\"","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/anv-pvw\/677\/D4A\/677D4AE66D2B449D959C5C4AA5B09FEA_5.jpg?Expires=1688947200&KeyName=mcpkey1&Signature=U-pSUgH12kiTeG_s5xKQ50VCIfc","uploadDate":"2020-07-09","duration":"T5M38S","contentUrl":"https:\/\/lasvegas.cbslocal.com\/video\/4621175-ntare-guma-mbaho-mwine-on-showtimes-the-chi\/","embedUrl":"https:\/\/lasvegas.cbslocal.com\/video\/4621175-ntare-guma-mbaho-mwine-on-showtimes-the-chi\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.VEGAS","default",["weneedtohavediversestoriesntaregumambahomwineonshowtimesthechi","post","article","entertainment","onlycbs","common","djsixsmith","lenawaithe","ntaregumambahomwine","thechi","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="The star of &quot;The Chi&quot; on Showtime discusses the many layers of his character Ronnie Davis and why this show is so important today with the conversations happening nationally about racial injustice." />
<script>//<![CDATA[
//]]></script>

</head>

<body class="post-template-default single single-post postid-261329 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://lasvegas.cbslocal.com" id="header-logo"><img src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2018/07/2_cbs_lasvegas.png?w=244" alt="CBS Las Vegas" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://lasvegas.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://lasvegas.cbslocal.com/category/entertainment/">Entertainment</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/2020/07/09/second-stimulus-payment-check-how-much/" title="What Might A Second Stimulus Payment Look Like For You?" class="cbs-thumbnail-link item-1594331179" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/unemployment-line-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">What Might A Second Stimulus Payment Look Like For You?</strong><em class="description">A second stimulus payment grows more likely by the day, with coronavirus surging and the fate of the economy hanging in the balance.</em></div></a><a href="https://lasvegas.cbslocal.com/2020/07/09/ntare-guma-mbaho-mwine-the-chi/" title="&#039;We Need To Have Diverse Stories&#039;: Ntare Guma Mbaho Mwine On Showtime&#039;s &#039;The Chi&#039;" class="cbs-thumbnail-link item-1594326164" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/TheChi_303_0339_R-e1594320812153-11.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;We Need To Have Diverse Stories&#039;: Ntare Guma Mbaho Mwine On Showtime&#039;s &#039;The Chi&#039;</strong><em class="description">The star of &quot;The Chi&quot; on Showtime discusses the many layers of his character Ronnie Davis and why this show is so important today with the conversations happening nationally about racial injustice.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://lasvegas.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/2017/09/12/democratic-leader-ford-running-for-nevada-attorney-general/" title="Democratic Leader Ford Running for Nevada Attorney General" class="cbs-thumbnail-link item-1505258663" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2017/09/aaron-ford.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Democratic Leader Ford Running for Nevada Attorney General</strong><em class="description">The top Democrat in the Nevada Legislature announced Tuesday he is running for state attorney general.</em></div></a><a href="https://lasvegas.cbslocal.com/2017/05/23/nevada-permits-young-soldiers-to-carry-concealed-weapons/" title="Nevada Permits Young Soldiers to Carry Concealed Weapons" class="cbs-thumbnail-link item-1495555914" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2017/05/gun-waistband.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Nevada Permits Young Soldiers to Carry Concealed Weapons</strong><em class="description">Nevada is lowering the age requirement for permits to carry concealed weapons to 18 for active-duty soldiers and honorably discharged veterans.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://lasvegas.cbslocal.com/category/health/">HealthWatch</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/2020/07/01/coronavirus-summer-questions-kids-hiking-picnic-answers-dr-dave-hnida/" title="How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida" class="cbs-thumbnail-link item-1593619866" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/americans-picnic-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida</strong><em class="description">Dr. Dave Hnida answers common questions about staying safe from coronavirus this summer while still enjoying the warm weather and company of friends.</em></div></a><a href="https://lasvegas.cbslocal.com/2020/06/29/coronavirus-summer-questions-answers-vacation-camp-dr-max-gomez/" title="How Safe Is Going On Vacation? Summer Coronavirus Questions Answered By Dr. Max Gomez" class="cbs-thumbnail-link item-1593462368" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/bike-riders-miami-beach-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How Safe Is Going On Vacation? Summer Coronavirus Questions Answered By Dr. Max Gomez</strong><em class="description">With coronavirus limitations easing and summer in full swing, Dr. Max Gomez answers questions about safety while vacationing and enjoying outdoor activities.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://lasvegas.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/category/sports/" title="Latest Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest Sports</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="http://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a><a href="http://www.cbssports.com/nhl/" title="NHL" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">NHL</strong></div></a><a href="http://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://lasvegas.cbslocal.com/category/usually-wrong/">Featured</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/2020/07/09/taylor-fritz-world-team-tennis-philadelphia-freedoms-cbs/" title="&#039;Always Fun To Play As Part Of A Team&#039;: Taylor Fritz On Joining Philadelphia Freedoms, World Team Tennis For 2020 Season" class="cbs-thumbnail-link item-1594305936" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/GettyImages-1224903747.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;Always Fun To Play As Part Of A Team&#039;: Taylor Fritz On Joining Philadelphia Freedoms, World Team Tennis For 2020 Season</strong><em class="description">World Team Tennis kicks off its 2020 season starting this weekend July 12 and top American men&#039;s player Taylor Fritz is looking forward to having some fun with the team events.</em></div></a><a href="https://lasvegas.cbslocal.com/2020/07/09/uefa-champions-league-cbs-cbs-all-access/" title="CBS Now Home To UEFA Champions League, Other UEFA Competitions Beginning In August" class="cbs-thumbnail-link item-1594299152" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/GettyImages-1189006109.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Now Home To UEFA Champions League, Other UEFA Competitions Beginning In August</strong><em class="description">The network and its digital streaming platform CBS All Access will now air all UEFA Champions League, Europa League and Europa Conference League matches beginning in August.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link"><a href="http://lasvegas.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://lasvegas.cbslocal.com/category/top-spots/" title="Top Spots" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Top Spots</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://lasvegas.cbslocal.com/category/top-spots">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/2018/03/27/best-family-events-for-easter-in-las-vegas/" title="Best Family Events For Easter In Las Vegas" class="cbs-thumbnail-link item-1522159200 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2013/03/easter-bunny-dan-kitwood.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Family Events For Easter In Las Vegas</strong><em class="description">Easter is almost here. That means it&#039;s time to dust off those baskets and get ready for some fun right here in the Vegas Valley area.</em></div></a><a href="https://lasvegas.cbslocal.com/2018/03/13/best-ways-to-celebrate-st-patricks-day-in-las-vegas/" title="Best Ways To Celebrate St. Patrick&#039;s Day In Las Vegas" class="cbs-thumbnail-link item-1520949600 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2014/03/st-patty.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Ways To Celebrate St. Patrick&#039;s Day In Las Vegas</strong><em class="description">Locals and tourists love to celebrate St. Patrick&#039;s Day in Las Vegas, whether it is the food, beer or parades. Go for the green and check out these great ways to enjoy the Luck of  the Irish.</em></div></a><a href="https://lasvegas.cbslocal.com/2018/02/13/best-ways-to-support-las-vegas-local-art-scene/" title="Best Ways To Support Las Vegas&#039; Local Art Scene" class="cbs-thumbnail-link item-1518534000 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2014/05/art-lovers.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Ways To Support Las Vegas&#039; Local Art Scene</strong><em class="description">Art thrives in Las Vegas including artists, galleries and outdoor murals. Supporting the local art scene is a fun way to enjoy culture while appreciating the works of others.</em></div></a><a href="https://lasvegas.cbslocal.com/2018/02/07/best-locally-owned-coffee-shops-in-las-vegas/" title="Best Locally-Owned Coffee Shops In Las Vegas" class="cbs-thumbnail-link item-1518012000 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2018/02/foodie-gift-guide-coffee-e1519743408122.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Locally-Owned Coffee Shops In Las Vegas</strong><em class="description">Get some of the best freshly brewed coffee right here in the heart of Las Vegas.</em></div></a><a href="https://lasvegas.cbslocal.com/2018/01/30/best-crafty-classes-in-las-vegas/" title="Best Crafty Classes in Las Vegas" class="cbs-thumbnail-link item-1517328000 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2016/04/painting-e1517330628510.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Crafty Classes in Las Vegas</strong><em class="description">Learn to be more creative by taking one of the many craft and art classes in the Las Vegas area.</em></div></a><a href="https://lasvegas.cbslocal.com/2018/01/16/best-healthy-breakfasts-in-las-vegas/" title="Best Healthy Breakfasts In Las Vegas" class="cbs-thumbnail-link item-1516114800 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2014/07/breakfast-sandwiches.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Healthy Breakfasts In Las Vegas</strong><em class="description">A healthy breakfast is the best way to begin the day and these top places offers nutritious meals that are also tasty.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="http://lasvegas.cbslocal.com/category/entertainment/" title="Entertainment" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/2020/07/09/ntare-guma-mbaho-mwine-the-chi/" title="&#039;We Need To Have Diverse Stories&#039;: Ntare Guma Mbaho Mwine On Showtime&#039;s &#039;The Chi&#039;" class="cbs-thumbnail-link item-1594326164" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/TheChi_303_0339_R-e1594320812153-11.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;We Need To Have Diverse Stories&#039;: Ntare Guma Mbaho Mwine On Showtime&#039;s &#039;The Chi&#039;</strong><em class="description">The star of &quot;The Chi&quot; on Showtime discusses the many layers of his character Ronnie Davis and why this show is so important today with the conversations happening nationally about racial injustice.</em></div></a><a href="https://lasvegas.cbslocal.com/2020/07/08/joy-osmanski-stargirl-interview/" title="&#039;I Feel Like Something In Me Has Been Unleashed&#039;: Joy Osmanski On The CW Network&#039;s &#039;Stargirl&#039; &amp; Luke Wilson" class="cbs-thumbnail-link item-1594235646" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/GettyImages-130222346-e1594233779559.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;I Feel Like Something In Me Has Been Unleashed&#039;: Joy Osmanski On The CW Network&#039;s &#039;Stargirl&#039; &amp; Luke Wilson</strong><em class="description">The actor discusses her breakout role in &quot;Stargirl&quot; and what it means to represent the Asian community in Hollywood.</em></div></a><a href="https://lasvegas.cbslocal.com/2020/06/30/amy-smart-dcs-stargirl-the-cw/" title="Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;" class="cbs-thumbnail-link item-1593532813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/stargirl11.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;</strong><em class="description">Amy Smart discusses her role as Barbara on The CW&#039;s &#039;DC&#039;s Stargirl.&#039;</em></div></a><a href="https://lasvegas.cbslocal.com/2020/06/26/natalie-dormer-nathan-lane-penny-dreadful-city-of-angels-season-one/" title="Natalie Dormer And Nathan Lane Talk Nailing It In &#039;Penny Dreadful: City Of Angels&#039;: &#039;A Great Challenge And A Lot Of Fun&#039;" class="cbs-thumbnail-link item-1593202442" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/pennyfeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Natalie Dormer And Nathan Lane Talk Nailing It In &#039;Penny Dreadful: City Of Angels&#039;: &#039;A Great Challenge And A Lot Of Fun&#039;</strong><em class="description">Natalie Dormer and Nathan Lane discuss quarantine and the season one finale of &#039;Penny Dreadful: City Of Angels&#039; on SHOWTIME.</em></div></a><a href="https://lasvegas.cbslocal.com/2020/06/25/beyonce-knowles-carter-humanitarian-award-bet-awards/" title="Beyoncé Knowles-Carter To Receive Humanitarian Award At &#039;BET Awards 2020&#039;" class="cbs-thumbnail-link item-1593107644" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/GettyImages-635009988.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Beyoncé Knowles-Carter To Receive Humanitarian Award At &#039;BET Awards 2020&#039;</strong><em class="description">Beyoncé Knowles-Carter will receive a humanitarian award at the BET Awards 2020.</em></div></a><a href="https://lasvegas.cbslocal.com/2020/06/24/bet-awards-nas-public-enemy-black-thought/" title="Questlove, YG, Nas And Public Enemy Among Newly Announced BET Awards Performers" class="cbs-thumbnail-link item-1593014439" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/GettyImages-980913726.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Questlove, YG, Nas And Public Enemy Among Newly Announced BET Awards Performers</strong><em class="description">The BET Awards have announced more performers for this weekend&#039;s ceremony including Black Thought, Jay Rock and Karen Clark Shead.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://lasvegas.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2019/08/GettyImages-466663843-16.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://lasvegas.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://lasvegas.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2019/04/igworthy.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://lasvegas.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2019/04/187774436.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a><a href="https://lasvegas.cbslocal.com/2019/04/04/final-four-guide-5-restaurants-near-u-s-bank-stadium/" title="Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium" class="cbs-thumbnail-link item-1554410992" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2019/04/107277389-e1538670804895.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium</strong><em class="description">In Minneapolis for the Final Four and want to try the restaurants where Minneapolitans love to eat? Look no further. Below are some of the most beloved spots in the City of Lakes within walking distance, or a short Lyft ride, from U.S. Bank Stadium.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Events</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://lasvegas.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1367432199" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2013/05/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://lasvegas.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">&#8216;We Need To Have Diverse Stories&#8217;: Ntare Guma Mbaho Mwine On Showtime&#8217;s &#8216;The Chi&#8217;</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">July 9, 2020 at 1:22 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://lasvegas.cbslocal.com/tag/common/">Common</a>, <a href="https://lasvegas.cbslocal.com/tag/dj-sixsmith/">DJ Sixsmith</a>, <a href="https://lasvegas.cbslocal.com/tag/lena-waithe/">Lena Waithe</a>, <a href="https://lasvegas.cbslocal.com/tag/ntare-guma-mbaho-mwine/">Ntare Guma Mbaho Mwine</a>, <a href="https://lasvegas.cbslocal.com/tag/the-chi/">The Chi</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id='p0'></div><script type="text/plain" class="optanon-category-4" async  data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4621175&quot;,&quot;autoplay&quot;:true,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p0&quot;,&quot;plugins&quot;:{&quot;heartbeat&quot;:{&quot;account&quot;:&quot;cbslocal-global-unified&quot;,&quot;publisherId&quot;:&quot;cbslocal&quot;,&quot;jobId&quot;:&quot;sc_va&quot;,&quot;marketingCloudId&quot;:&quot;823BA0335567497F7F000101@AdobeOrg&quot;,&quot;trackingServer&quot;:&quot;cbsdigitalmedia.hb.omtrdc.net&quot;,&quot;customTrackingServer&quot;:&quot;cbsdigitalmedia.d1.sc.omtrdc.net&quot;,&quot;chapterTracking&quot;:false,&quot;version&quot;:&quot;1.5&quot;},&quot;comscore&quot;:{&quot;clientId&quot;:&quot;3000023&quot;,&quot;c3&quot;:&quot;Lasvegas.cbslocal.com&quot;},&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.VEGAS&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;featured&quot;}}}},&quot;shareLink&quot;:&quot;https:\/\/cbsloc.al\/3iIsZpP&quot;,&quot;video-type&quot;:&quot;featured&quot;,&quot;token&quot;:&quot;default&quot;,&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script></div></section>
<div class="main-story-wrapper"><p><strong>(CBS Local)&#8211; </strong>&#8220;The Chi&#8221; is in its third season on Showtime and the series has featured many breakout stars like&nbsp;Ntare Guma Mbaho Mwine.</p>
<p>Mwine plays Ronnie Davis, a man who has been through many ups and downs in his life. Davis served in the military, killed a kid, got shot by another kid, went to prison and battled addiction. All of that happens in the first two seasons of the show and in season three, Mwine says Davis is starting to figure out who he will be going forward.</p>
<p>&#8220;It&#8217;s like a Greek tragedy, but it&#8217;s a Chicago South Side tragedy,&#8221; said Mwine in an interview with CBS Local&#8217;s DJ Sixsmith. &#8220;The trials and tribulations, the ups and downs. What&#8217;s incredible is that I&#8217;m discovering it along the way. For example, a big reveal at the end of season two was that Ronnie grew up across the street from the person that was his dad. No one ever said it openly, but he knew. That&#8217;s a pretty significant insight into a character, but I only found out that in the latter part of the second season. There&#8217;s all these major traumas and major events in this character&#8217;s life that I wonder how they would play in retrospect. Season three was the first time the writers told me the arc of the story for the season, which actually helped me playing the role.&#8221;</p>
<p><strong>FULL INTERVIEW:</strong></p>
<div id='p1'></div><script type="text/plain" class="optanon-category-4" async  data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4621171&quot;,&quot;autoplay&quot;:false,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p1&quot;,&quot;plugins&quot;:{&quot;heartbeat&quot;:{&quot;account&quot;:&quot;cbslocal-global-unified&quot;,&quot;publisherId&quot;:&quot;cbslocal&quot;,&quot;jobId&quot;:&quot;sc_va&quot;,&quot;marketingCloudId&quot;:&quot;823BA0335567497F7F000101@AdobeOrg&quot;,&quot;trackingServer&quot;:&quot;cbsdigitalmedia.hb.omtrdc.net&quot;,&quot;customTrackingServer&quot;:&quot;cbsdigitalmedia.d1.sc.omtrdc.net&quot;,&quot;chapterTracking&quot;:false,&quot;version&quot;:&quot;1.5&quot;},&quot;comscore&quot;:{&quot;clientId&quot;:&quot;3000023&quot;,&quot;c3&quot;:&quot;Lasvegas.cbslocal.com&quot;},&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.VEGAS&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;video-default&quot;}}}},&quot;token&quot;:&quot;default&quot;,&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script>
<p>The star of &#8220;The Chi&#8221; says the experience has been a dream come true. While the topics covered on the show have always been weighty, Mwine believes this season is even more important following the death of George Floyd and the nationwide conversations surrounding racial injustice.</p>
<p>&#8220;We need to have diverse stories representing diverse backgrounds,&#8221; said Mwine. &#8220;What&#8217;s so great about this show is it covers a spectrum just from the kids, who actually steal the show. &#8220;It&#8217;s really refreshing to be able to see a range of representation on that show and to be able to have that airing now. It feels like a blessing because it resonates differently than it could&#8217;ve before. We&#8217;re all looking for something to do that&#8217;s a release and I think that&#8217;a good show to do that.&#8221;</p>
<p>While Mwine has worked with many great actors in the past like Leonardo DiCaprio is the film &#8220;Blood Diamond,&#8221; the actor says spending time on and off the screen with Academy Award and GRAMMY winner Common has been an incredible experience.</p>
<p>&#8220;Common is amazing. His name Common, he&#8217;s like the soil,&#8221; said Mwine. &#8220;He&#8217;s just the real deal. He&#8217;s the every man and keep it real. I remember he invited me to come hang out and hang in his dressing room and that&#8217;s rare for someone on that level. He really was an open book.&#8221;</p>
<p>Watch &#8220;<a href="https://www.sho.com/the-chi" target="_blank" rel="noopener noreferrer">The Chi</a>&#8221; on Showtime Sundays at 9 p.m. EST/PST and the Showtime Anytime App.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3iIsZpP"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3iIsZpP"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3iIsZpP"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSLocal/" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="http://twitter.com/CBSLocal" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://lasvegas.cbslocal.com/2016/08/10/the-list-of-clinton-associates-whove-died-mysteriously-check-it-out/" title="The List of Clinton Associates Who Allegedly Died Mysteriously. Check It Out." class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://secure.gravatar.com/avatar/7070efc358943cf9de8efe48230db177?s=55&#038;d=mm&#038;r=g" alt="The List of Clinton Associates Who Allegedly Died Mysteriously. Check It Out." data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2016/08/10/the-list-of-clinton-associates-whove-died-mysteriously-check-it-out/" title="The List of Clinton Associates Who Allegedly Died Mysteriously. Check It Out." class="bump-view" data-bump-view="tp">The List of Clinton Associates Who Allegedly Died Mysteriously. Check It Out.</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/06/24/bet-awards-nas-public-enemy-black-thought/" title="Questlove, YG, Nas And Public Enemy Among Newly Announced BET Awards Performers" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/GettyImages-980913726.jpg?resize=55%2C55&#038;ssl=1" alt="Questlove, YG, Nas And Public Enemy Among Newly Announced BET Awards Performers" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/06/24/bet-awards-nas-public-enemy-black-thought/" title="Questlove, YG, Nas And Public Enemy Among Newly Announced BET Awards Performers" class="bump-view" data-bump-view="tp">Questlove, YG, Nas And Public Enemy Among Newly Announced BET Awards Performers</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/06/29/coronavirus-summer-questions-answers-vacation-camp-dr-max-gomez/" title="How Safe Is Going On Vacation? Summer Coronavirus Questions Answered By Dr. Max Gomez" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/bike-riders-miami-beach-1.jpg?resize=55%2C55&#038;ssl=1" alt="How Safe Is Going On Vacation? Summer Coronavirus Questions Answered By Dr. Max Gomez" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/06/29/coronavirus-summer-questions-answers-vacation-camp-dr-max-gomez/" title="How Safe Is Going On Vacation? Summer Coronavirus Questions Answered By Dr. Max Gomez" class="bump-view" data-bump-view="tp">How Safe Is Going On Vacation? Summer Coronavirus Questions Answered By Dr. Max Gomez</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/06/26/natalie-dormer-nathan-lane-penny-dreadful-city-of-angels-season-one/" title="Natalie Dormer And Nathan Lane Talk Nailing It In &#039;Penny Dreadful: City Of Angels&#039;: &#039;A Great Challenge And A Lot Of Fun&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/pennyfeat.jpg?resize=55%2C55&#038;ssl=1" alt="Natalie Dormer And Nathan Lane Talk Nailing It In &#039;Penny Dreadful: City Of Angels&#039;: &#039;A Great Challenge And A Lot Of Fun&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/06/26/natalie-dormer-nathan-lane-penny-dreadful-city-of-angels-season-one/" title="Natalie Dormer And Nathan Lane Talk Nailing It In &#039;Penny Dreadful: City Of Angels&#039;: &#039;A Great Challenge And A Lot Of Fun&#039;" class="bump-view" data-bump-view="tp">Natalie Dormer And Nathan Lane Talk Nailing It In &#039;Penny Dreadful: City Of Angels&#039;: &#039;A Great Challenge And A Lot Of Fun&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/06/25/beyonce-knowles-carter-humanitarian-award-bet-awards/" title="Beyoncé Knowles-Carter To Receive Humanitarian Award At &#039;BET Awards 2020&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/GettyImages-635009988.jpg?resize=55%2C55&#038;ssl=1" alt="Beyoncé Knowles-Carter To Receive Humanitarian Award At &#039;BET Awards 2020&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/06/25/beyonce-knowles-carter-humanitarian-award-bet-awards/" title="Beyoncé Knowles-Carter To Receive Humanitarian Award At &#039;BET Awards 2020&#039;" class="bump-view" data-bump-view="tp">Beyoncé Knowles-Carter To Receive Humanitarian Award At &#039;BET Awards 2020&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/07/01/coronavirus-summer-questions-kids-hiking-picnic-answers-dr-dave-hnida/" title="How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/americans-picnic-1.jpg?resize=55%2C55&#038;ssl=1" alt="How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/07/01/coronavirus-summer-questions-kids-hiking-picnic-answers-dr-dave-hnida/" title="How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida" class="bump-view" data-bump-view="tp">How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/06/30/amy-smart-dcs-stargirl-the-cw/" title="Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/stargirl11.jpg?resize=55%2C55&#038;ssl=1" alt="Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/06/30/amy-smart-dcs-stargirl-the-cw/" title="Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;" class="bump-view" data-bump-view="tp">Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/07/01/rocket-mortgage-classic-preview-detroit-golf-club-bryson-dechambeau-nick-faldo-interview/" title="&#039;20-Under Might Not Win It If Greens Are Soft&#039;, Says Nick Faldo On Rocket Mortgage Classic" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/nate-lashley-rocket-mortgage-2019-1.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;20-Under Might Not Win It If Greens Are Soft&#039;, Says Nick Faldo On Rocket Mortgage Classic" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/07/01/rocket-mortgage-classic-preview-detroit-golf-club-bryson-dechambeau-nick-faldo-interview/" title="&#039;20-Under Might Not Win It If Greens Are Soft&#039;, Says Nick Faldo On Rocket Mortgage Classic" class="bump-view" data-bump-view="tp">&#039;20-Under Might Not Win It If Greens Are Soft&#039;, Says Nick Faldo On Rocket Mortgage Classic</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/06/30/detroit-golf-club-profile-preview-rocket-mortgage-classic/" title="Detroit Golf Club Profile: Historic Course Faces Modern Game At Rocket Mortgage Classic" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/06/rocket-mortgage-classic.jpg?resize=55%2C55&#038;ssl=1" alt="Detroit Golf Club Profile: Historic Course Faces Modern Game At Rocket Mortgage Classic" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/06/30/detroit-golf-club-profile-preview-rocket-mortgage-classic/" title="Detroit Golf Club Profile: Historic Course Faces Modern Game At Rocket Mortgage Classic" class="bump-view" data-bump-view="tp">Detroit Golf Club Profile: Historic Course Faces Modern Game At Rocket Mortgage Classic</a>
							</div>
													</li>
										<li>
						<a href="https://lasvegas.cbslocal.com/2020/07/01/ben-widdicombe-gatecrasher-donald-trump-interview/" title="&#039;Donald Trump Is Completely One-Dimensional&#039;: Ben Widdicombe On New Book &#039;Gatecrasher&#039; &amp; Evolution Of Celebrity Culture" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2020/07/GettyImages-53007813-e1593634694253.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;Donald Trump Is Completely One-Dimensional&#039;: Ben Widdicombe On New Book &#039;Gatecrasher&#039; &amp; Evolution Of Celebrity Culture" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://lasvegas.cbslocal.com/2020/07/01/ben-widdicombe-gatecrasher-donald-trump-interview/" title="&#039;Donald Trump Is Completely One-Dimensional&#039;: Ben Widdicombe On New Book &#039;Gatecrasher&#039; &amp; Evolution Of Celebrity Culture" class="bump-view" data-bump-view="tp">&#039;Donald Trump Is Completely One-Dimensional&#039;: Ben Widdicombe On New Book &#039;Gatecrasher&#039; &amp; Evolution Of Celebrity Culture</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://lasvegas.cbslocal.com" class="logo"><img src="https://lasvegas.cbslocal.com/wp-content/uploads/sites/15909905/2017/10/lasvegas.png" alt="CBS Las Vegas" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSLocal/" class="facebook" target="_blank">Facebook</a><a href="http://twitter.com/CBSLocal" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="http://lasvegas.cbslocal.com/us-news/" title="US News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">US News</strong></div></a><a href="http://lasvegas.cbslocal.com/world-news/" title="World News" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">World News</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://lasvegas.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://lasvegas.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="http://lasvegas.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://lasvegas.cbslocal.com/category/autos/" title="Autos" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Autos</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://lasvegas.cbslocal.com/site-info/" title="Station Info" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Station Info</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://lasvegas.cbslocal.com" class="logo"><img src="https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Las Vegas" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=lasvegas.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-68969" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68969"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-68967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68967"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-258967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-258967"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-258968" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-258968"><a href="https://ca.privacy.cbs/donotsell">California Do Not Sell My Info</a></li>
<li id="menu-item-187899" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-187899"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://lasvegas.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1585779545g' type='text/css' media='all' />
<script type='text/javascript' src='https://lasvegas.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1591831597g'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202028.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.0.1',blog:'162246000',post:'261329',tz:'-7',srv:'lasvegas.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246000', '261329' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>